User Portal Upgrade Ongoing
Incident Report for Nook
Resolved
This incident has been resolved.
Posted Feb 25, 2024 - 08:50 GMT+08:00
Update
We are continuing to investigate this issue.
Posted Feb 24, 2024 - 11:46 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Feb 24, 2024 - 11:45 GMT+08:00
This incident affected: Website (Website User Portal).